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NAQCC SprintLogger User Guide
This guide contains the following chapters:

l Getting Started
l Logging
l Editing and Deleting Log Entries
l Managing Multiple Radios
l ADIF Log Files
l The Tools Menu
l Appendices

Getting Started
The following subjects will get you started:

l Updating Membership Data
l Setting Program Options
l Connecting to a Radio
l Starting a Log File
l The File Menu

Updating Membership Data
When you first start using the SprintLogger you should see the Main Logging Window that will look something like this:

One of the first things you should do is to update the local membership database with the latest data available from NAQCC. It is also very important that you perform this 
before every monthly sprint. As of this writing, the NAQCC membership data file is updated monthly, usually a few days prior to the next sprint, and is available as a zip file 
download from www.naqcc.info/naqcc.zip.
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I have tried to make this process as easy as possible, the logger will help you download the membership data zip file but you will need to save the zip file, check the ReadMe 
text file, and save the NAQCC.dat file to the NAQCC Logger's installation folder.

There are multiple ways to initiate the membership download process but the simplest is to click on the underlined membership information in the lower left corner just below 
the log listing.

When you initiate a membership update, the Update Membership Data window will open.

Clicking on the "Download NAQCC.zip Data File" will launch your default Browser to the download page which should open a Save file dialog window.

After you save the zip file to a known location on your PC you then need to open the zip file and look at the contents. When you open the zip file you should see something 
like this:
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You should pay close attention to the dates of the files. They should be dated within a day or two of the next sprint. To be sure you have the correct download file, just open 
and read the ReadMe.txt file. Once you have confirmed the correct file, you will need to save the NAQCC.dat file to the same folder that the SprintLogger is installed in. By 
default, that folder is C:\NAQCC SprintLogger and that folder should already have a file by the same name existing already.
Note: The easiest way to save the file is with a simple drag/drop mouse operation.

Finally, you MUST tell the SprintLogger to load the NAQCC.dat file information into the local membership database. Just click on the "Load NAQCC.dat File" push button 
to complete the process. When the membership data has been loaded the window should look something like this:

If the membership information was loaded correctly, the "Max Mbr Nr in DB:" displayed in the lower left corner of the main logger window should match the "highest 
member number included" mentioned in the Readme.txt file.
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Next Chapter: Setting Program Options

Setting Program Options
The second thing you should do is set some program options and update the membership file.

This program utilizes two primary windows: a main window that carries the full listing of QSOs, and a Log Entry window, which appears after you click on the main 
window's "Start Logging" button. To begin program set-up, from the main Logger window select the "Options" menu item and then select "Set Program Options."

When you select "Set Program Options," the "Program Options" window will open. Here, you can specify the following options:
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Logging Defaults

l Enter default values for RST Received, RST Sent, and TX Power. These are optional settings that you can use to speed the logging process - you may leave the fields 
blank if you prefer. 

l You can also update the Membership File with the latest information as described in the previous section. 
l Some members have requested to be able to separate NAQCC QSOs from others. If you have no interest in this information, just leave it blank. However, if you want to 

use this feature, you can set the "Contest ID" to "NAQCC Sprint" or any other description that you want to use. Note: This information is saved as ADIF Tag
CONTEST_ID. 

My Station

l You MUST enter the Callsign you use in the NAQCC sprint into this field. This callsign is used in generating the output report for AutoLogger. This Callsign and your 
NAQCC Number are displayed in the Title of the Add Log Entry window. That places the information immediately in front of you while logging a QSO. This value 
will also be included in a saved log file as the "STATION_CALLSIGN" tag. 

l Operator Callsign is used to designate the callsign of an operator who is NOT the station callsign - usually used for club stations. This value, if entered, will be included 
in the saved log file as the "OPERATOR" tag. 

General Program Options

l Checking the "Copy NAQCC Number to Comment Field" tells the program to copy the NAQCC Number, Name, and SPC for members to the Comment field. 
l The "Refill Log List After Window Resize" option tells the program how to behave whenever you resize the main window. If you check this option, the QSO list in the 

main window will be refilled so that the latest entry is displayed as the last line on the list. You may want to play around with this option to see which setting you prefer. 
l By default, the SprintLogger will remember and recall the last position and size of many of the windows that the program uses. If you do not want this option, just

uncheck the checkbox next to "Remember Window Positions Sizes." 
l With the "Recent Logs List: Maximum Count" option, you can set the number of recent logs the program will maintain on the File Menu's "Re-Open Recent Logs" list.

¡ You can specify any number between 2 and 25. 
¡ Note: If you have more log files than the number you specify, the list of recent logs will start with your most recently opened log, then be trimmed to the number

of logs that you enter. 
l At startup time, the logger checks the date of the last update of the local membership file and will provide a reminder if the age is greater than the number entered here. 

Entering a Zero (0) will disable file age reminders. 
l The default font used for all Text Fields in the SprintLogger is the "System" Font defined by your PC's Operating System. Some users have found that different fonts 

make the displays easier on the eyes. You can experiment with fonts here. Please note the following:
¡ Any font you select is immediately used to fill the text fields within the Program Options Window. This gives you a quick preview of what the font looks like. 
¡ If you want to select a different font, your MUST "Save" your settings before closing the Program Options Window. 
¡ When you change the font, the new font will be applied only to the Main SprintLogger Window. Any other open windows will need to be closed and re-opened in 

order to display using the newly selected font. 

Log List Columns

On the right side of the "Program Options" window you will find a list of the columns the main window's QSO list can display. Use the checkboxes to customize the amount 
of data the log dislays - especially useful on older machines with smaller screens.

Note: All of the fields on the checklist are saved in the log file whether or not you select them for display. Also note that the Row ID, Date, Time, and Callsign are not
optional display items.

When you are done, click the "Save" button to save your settings and close the Program Options window.

Next Chapter: Connecting to a Radio
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Connecting to a Radio
If you have a supported radio connected to your PC, you will want to tell the program about your radio so that the logger can read and set the VFO for you.

From the main SprintLogger window, select the "Options" menu item and then select "Configure Radio."

When you select the "Configure Radio" option, the "Radio Setup" window will open.

The "Config Name" pull-down menu provides you with a way of naming your radio configuration. Providing a unique name for your radio configuration is most useful when 
you have two or more radios that you use with the logger. However, even with one radio connected, you need to assign a name to the settings.

If you have previously had a radio connected with an early version of the SprintLogger, that radio's setup will be recalled, preset, and will be given a default name of "My 
Radio Setup" as shown in the image below. You will be able to change the configuration name later. But for now, just continue.

If you have never configured a radio before, you will start with a "New Config." In this case, you will be prompted later (when you try to open the port) to provide a 
configuration name.

The two different initial scenarios are shown in the following screenshots:

Details on managing multiple radio configurations is provided in the Managing Multiple Radios chapter.

The following steps will connect the SprintLogger program to your radio:

l Click the pull-down menu next to "Radio Model" to see if your specific radio model is supported. Selecting your radio model will preset certain settings and also 
display a small set of helpful information specific to the radio model selected. 

l Click the pull-down menu next to "COM Port" and select the specific COM port that your radio is connected to. Only COM ports that are currently available through 
your operating system will appear in the menu listing. 

¡ Note to Linux Users: If you intend to run this program on Linux via Wine, please see "Note to Linux Users" in the Appendix before proceeding with the rest of 
this step.

l Click the pull-down menu next to "Baud Rate" and select the baud rate as set in the menu system of your specific radio. Only Baud Rates that are valid for your selected 
radio model will appear in the menu listing.

l Click the pull-down menu next to "Parity" and select the parity setting required for your radio. If unknown, leave as set by the program or select "None." To date, none 
of the radios supported by the SprintLogger use any parity bits. 

l Click the pull-down menu next to "Stop Bits" and select the value required for your radio. If unknown, leave as set by the program or select "1.0." 
l The Icom interface uses a "CI-V Port" address that is unique to each model of radio. Unless you have changed the default setting for your Icom, the default value 

provided by the program should work. The "Icom CI-V" text field will be disabled (grayed out) and preset to "N/A" unless an Icom radio using the CIV protocol has 
been selected. 
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Some radio interfaces use either hardware or software "handshake" controls so that the radio can control when the PC can interact with it. The Radio Setup window provides 
options to select any of five different types of handshake interfaces. The checkbox options provide the following:

l CTS-FC enables CTS/RTS Hardware flow control; 
l DTR-FC enables DTR/DSR Hardware flow control; 
l Xon/Xoff enables Xon/Xoff Software flow control; 
l DTR ON causes the DTR control line to be asserted; 
l RTS On causes the RTS control line to be asserted. 

Once you have entered all required information, the "Open Port" button should be enabled. Click the button to open the port to the radio.

If you are setting up a "New Config," the program will prompt you to enter a name for the configuration. Enter any descriptive name you like. Just note that all radio 
configuration names must be unique and that "New Config" is a reserved name. Press the "Save Name" button when you have entered your configuration name.

If the COM port opened successfully, the message "Radio Port Opened" should appear under the "Open Port" button and the button should now be a "Close Port" button.

If the COM port failed to open, check your settings carefully and try again. A common reason (in fact the ONLY reason I have seen so far) for failing to open is that the COM 
Port is already in use by another program - maybe another logging program?

You should also be aware the a successful opening of the COM port ONLY means that the logger has connected to the port. Proper exchange of information through that port 
is a different challenge altogether.

If you are certain that all other settings are correct but you still cannot read or write to your radio's VFO-A frequency, you may want to experiment with various flow-control 
settings. Keep in mind, however, that opening a COM port on a PC does little more than connect the COM port to the program that opened the port. No data is actually passed 
at this point.

The next steps actually use the COM port to communicate with the radio.

Once you have opened the radio port, the next step is to test setting or reading the primary VFO.

l Click the "Read VFO" button to send a command to the radio. 
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You might see some data displayed in the "Raw Data Received From Radio" text box, but it is probably not important to you. If the radio responds as expected, the frequency 
(in MHz) should display in the text box directly above the "Set VFO" and "Read VFO" buttons.

Note: The "Copy to Clipboard" button can be used to copy/paste all of the data displayed in the "Raw Data Received From Radio" to the Windows clipboard. In the event that 
you have problems with your radio interface, the software-support team may request that you send a copy of the data being sent from the radio. This button makes it easier to 
transfer the data to an email or text file.

If the COM port opened successfully, but you are unable to read or set the VFO, then you need to carefully check the various settings that you selected above:

l Make certain that you have selected the correct COM port - the one that actually connects to the radio. 
l Make certain that there is a cable connecting the COM port to the radio and that all cable connections are firmly in place.
l Check the baud rate to make sure it matches the baud rate set in the radio. Check you user manual for "CAT" control instructions. 
l Try various stop-bit settings and flow-control combinations. 

Once you have set the COM port parameters correctly and have successfully read the VFO frequency, you should be able to enter a frequency into the text box and set your 
primary VFO.

When you are connected to a radio and start logging with "Auto Freq and Band" enabled, the program will periodically read the frequency from the radio. By default, the 
radio is polled for data every 15 seconds. You can specify a polling rate (in seconds) with a minimum of 1 second and a maximum of 999 seconds allowed. The default rate is 
once every 15 seconds.

When you have completed setting up your radio, click on the "Close Window" button to exit and leave the radio connected.

DO NOT click the "Close Port" button unless you want to deactivate the program's ability to read and set your radio's VFO.

Don't worry about trying to remember the specific settings you used to connect to the radio - the program remembers the settings in its initialization file.

When you exit from the Radio Setup Dialog window, the main logging window should reappear.

Next chapter: Starting a Log File

Starting a Log File
Before you start to log Sprint QSOs, you should start a new log for the Sprint. The program can handle large ADIF log files, but it is currently designed to use smaller log files 
with only a few hundred entries. You should get into the habit of starting a new log file for each sprint. You can merge them later with any master log you may be keeping 
with SprintLogger.

To start a new log file:
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l Select "Start New ADIF Log File" from the File menu in the main SprintLogger window. 
l You will see a "Create New ADIF Log File" dialog box that should show the current contents of the folder where your current log resides. By default, logs are created 

in the 'C:\NAQCC SprintLogger\Logs' folder. If, for whatever reason, the opened directory is not the folder containing your current log file, use the navigation tools to 
navigate to the correct directory. 

l Enter the name of your log file. For example, one common format would be "yyyy-mm-dd Sprint Log.adi." But whatever you pick, it should work fine. If the file name 
you enter does not exist, the SprintLogger will create it. If you enter or select an existing file name, SprintLogger will warn you that the file exists. If you select an 
existing file anyway, SprintLogger will erase it and the file will open empty - be careful what you request. 

l Once you have created a new log file, the "Create New ADIF Log File" dialog should close and the log file name should appear in the lower left corner of the main 
window. 

Note from the SprintLogger Author, AC2C

Over the past few years I have been asked several times for advice on how to organize log files. There are many ways to do this and I offer here advice based on how I handle 
my logs - do whatever works well for you. As mentioned previously in this User Guide, the SprintLogger was originally developed to serve as a sprint logger - logging a 
single NAQCC sprint event. In fact, the sprint statistics displayed in the lower right corner of the main log display window ASSUME that the current log represents a single 
sprint event. If your log spans more that a single sprint event, then those numbers are of little use to you.

There are many logging programs available for you - shop around and settle on whatever you like. Personally, I currently use Ham Radio Deluxe (HRD) as my master log
program - ALL of my radio activity is contained in the HRD log file. However, I use the SprintLogger throughout the month to log my NAQCC activities. Here is what I do -
take it for whatever it's worth to you:

l At the beginning of each month, I create a log file for my monthly NAQCC activity. This log is named 'NAQCC-AC2C-mm-yy' and this log will, at month's end,
contain ALL NAQCC activity for the month. 

l For any special sprints or other activities during the month, I create a separate log for each event. These individual logs then provide immediate statistics for the event 
that I can use to submit to the NAQCC webpage as my activity for the event. 

l Following each special event and my submission, I then use the File menu "Merge Log" function to merge the sprint log into my monthly log. 
l Continuing this process for each sprint/event during the month, by the end of the month I have a few logs that were used for each sprint/event but I also have one log 

that contains ALL of my NAQCC activity for the month. I can use that single log to summarize my monthly NAQCC activity and then merge that log into my HRD 
master log for upload to LoTW. 

l As a final step at the end of each month, I merge my monthly log into an NAQCC Master Log that contains ALL of my NAQCC activity since I started tracking it. 
l As they say in the ads, your mileage may vary (YMMV), but that's what I do. 

Next chapter: The File Menu
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The File Menu
In addition to the "Start New ADIF File" option, you have other options under the File Menu as well.

l "Open Existing ADIF Log File" allows you to open an existing log. After the log opens, new entries will be appended to the file. 
l "Print Log Data" allows you to print out the current log. The text format is fixed as Courier, 8-point font, and you should print in Landscape format to maximize the 

data a page displays. An ellipse (...) at the right-most end of a line indicates that additional information has been truncated. 
l "Save Log" saves the current log file to capture any changes made since the last save.
l "Save Log As ..." saves the current log "as is," gives it a new name, then continues using the new log file. 
l "Save Selected As ..." will save highlighted rows in the main window to a fresh ADIF log file. By using the "Merge ADIF File Into Current Log" function (see below), 

you can add these entries to an existing log. 
¡ You can select or de-select individual rows with a CTRL-click and select a range of rows with a SHIFT-Click.
¡ Be careful: If you attempt to use the "Save Selected As ..." function to save directly to an existing log, you will overwrite the existing file and it will display only 

the entries you are trying to transfer. If you try to save selected entries directly to an existing file, you will see a warning asking you if you really want to 
overwrite the existing file. Again, save the selected entries to a new file and use the merge function described below to add them to an active log.

l "Open AutoLogger Webpage" will launch your default web browser and open the NAQCC AutoLogger web page ready for you to enter your sprint results. You do not 
have to use this method, but I like to skip the extra steps of opening the NAQCC page and finding the AutoLogger page. 

l "Create AutoLogger Report" will save a copy of the text data that the NAQCC Website AutoLogger expects as input following a sprint. By default, the text file will be 
named the same as the log file with "-AutoLogger" appended to the log file name and will be saved in the same folder as the log file. After the AutoLogger report file 
has been saved as a text file, the text file will be opened with a text editor where you can "Select All" and then copy/paste into the AutoLogger webpage. Since the 
AutoLogger text is saved in a separate text file, you can always wait and submit your data later. 

l "Export to Excel-Format CSV File" saves the current log file data to a comma-delimited text file that can load into MS Excel or other compatible spreadsheet programs. 
l "Export to Pipe-Delimited Text File" saves the current log file data into a pipe-delimited text file. The text file can easily be examined and manipulated with a simple 

text editor or with a spreadsheet program, such as MS Excel. 
l "Merge ADIF File Into Current Log" merges an existing ADIF log file into the current log file. This option provides a way to combine multiple log files into one master 

log. Note that duplicate log entries (same Date, Time, Callsign, and Band) will not be added to the current log. 
l "Re-Open Recent Logs" allows you to quickly find and re-load recently opened log files. The number of recent logs is five by default or the number of logs you

specified during program set-up. 
l "Clear Recent Log List" will delete all except the current log file from the recent-log list. 

¡ You can specify the number of recent logs to be maintained via the Options menu in the SprintLogger's main window. 
l "Exit" saves any changes to the currently active log file and shuts down the SprintLogger program.

Next section: Logging
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Logging
The SprintLogger was designed with the "keep it simple" principle in mind.

Logging can be:

l Completely manual, requiring you to enter every detail;
l Semi-automatic, requiring you to enter some information; or 
l Fully automatic, requiring minimal data entry. 

The SprintLogger program can:

l Get the current date and time from the computer. 
l Get the frequency and band from the radio - if connected and configured. 
l Get a member's NAQCC number, name, and SPC from the membership data list. 
l Use the preset defaults for RSTs and TX power that you specified during set-up.
l Copy the member's NAQCC number, name, and SPC to the Comment field.
l Use "Enter" as the default action to add a log entry or require that you press a button to add an entry. 

All of the above actions are options that you can select to suit your specific logging style and needs.

The following subjects in this section will get you started on log entries:

l Logging a QSO
l Sprint Logging
l Submitting to AutoLogger 
l Tracking Sprint Statistics and SPC Details
l Timing the Length of a QSO

Logging a QSO
Once you have set program options, configured a radio interface (if you have a radio connected), and opened a log file, you are ready to start adding QSOs to your log.

To open the Log Entry window, click the "Start Logging" button on the main window.

Many options and variables can affect how you use the Log Entry window and how the Log Entry reacts to your actions. Let's take a moment to look over the basic window 
and discuss the options available:

l Some users want a logger to auto-fill as much as possible, while others want to fill everything manually; 
l Some users want to Tab from field to field, while others want to use the Enter key to move from field to field; 
l Some users want to have the Enter key be the default key used to complete a log entry, while others want to log only when they specifically click a button. 

It is difficult to create a program that suits everyone's desires, but I have tried my best to be as flexible as possible.

When the Log Entry window is first opened, it should look much like the image below. Some minor differences between what you see and what is shown below are:

l If you have configured and connected a radio: 
¡ The "Read VFO" checkbox will be checked;
¡ The "Freq" and "Band" fields will be disabled and will display the data from your radio; 
¡ The "QSY" field will be enabled. 
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A Quick Overview of the Log Entry Window

The first time you open the Log Entry window, you may be confused by all the buttons, labels, and text fields. Before you start making your first log entry, let's take a quick 
look at some of the fields and controls available.

l For real-time logging, checking the "Use PC Time" checkbox above the Date and Time fields will read the date and time from the PC and enter the information for you. 
When checked, the text fields are auto-filled every second and the fields are not editable. Anytime you want to enter a manual value, just uncheck the "Auto Date & 
Time" checkbox. SprintLogger will "remember" the setting when shutdown and restarted. 

¡ The current date and time will be frozen after the callsign entry is completed and you exit the Callsign text field. The QSO date and time will then remain frozen 
until the log entry is completed or the Callsign field is otherwise cleared.

n Note: You may click the "Now" button at any time to update the date and time entries to the current date and time.
¡ Note: The Date format presented and expected in the Date window is defined by the format you specified in your PC's Regional Settings set-up in your Windows 

Control Panel. Depending on your location and specific operating system, a variety of date formats are available. For example, the date 4 July 2012 could show in 
any of the following formats:
      07/04/2012 in MM/dd/yyyy format
     04/07/2012 in dd/MM/yyyy format

 12/07/04 in yy/MM/dd format
      2012-07-04 in yyyy-MM-dd format
      04.07.2012 in dd.MM.yyyy format
     etc, etc, etc 

l If you have configured and connected a supported radio, you may click the "Read VFO" check box located above the Freq/Band fields. If checked, the program will 
periodically poll your radio and update the frequency and band based on the information read from the radio's VFO-A. You designated the polling rate in the "Radio 
Setup" window. As you manually tune the radio, the displayed frequency and band information will be automatically updated. 

¡ Note: The "Read VFO" checkbox is not selectable unless you have configured a radio and have opened the COM port. Whenever a radio is connected, "Read 
VFO" is the default mode when you open the Log Entry window. 

¡ If you have connected a Radio, you can quickly QSY (i.e. set VFO-A) by entering a frequency into the "QSY" field and pressing TAB, ENTER, or the "QSY" 
button.

¡ Note: If you turn (scroll) your mouse wheel while the QSY text field is selected (has the current "focus"), the SprintLogger will increment or decrement your 
VFO-A Frequency at a rate of 100 Hz per wheel click. 

¡ The "Auto Clear" checkbox located above the "QSY" field affects the behavior of the text field whenever the cursor enters the field. If checked, the field will 
clear and be ready for a new entry. If unchecked, the field will retain its previous value and will be ready for editing. SprintLogger remembers your preference 
after the window is closed.

l Please note the "Auto-Fill" checkbox located to the right of the RST text fields. Check this box if you want the program to fill log fields based on information contained 
in the NAQCC membership file. 

l Clicking on the "QSO Notes" button will allow you to associate a set of personal notes to this callsign/member. 
l You will also notice the "Auto Log" checkbox located to the left of the "Log It" button. When selected, the ENTER key becomes the default "Log It" action whenever 

the minimum required logging information has been entered. 
l Logging a GridSquare is entirely optional and can be left blank for most log entries. However, if you enter a GridSquare value, it must be a valid value. A valid 

GridSquare sequence is defined as follows:
¡ A GridSquare sequence must be either 2, 4, 6, or 8 characters in length. 
¡ Valid Gridsquare alphanumeric characters (c1 c2 c3 c4 c5 c6 c7 c8) are as follows: 

n c1 & c2 must be between A and R 
n c3 & c4 must be between 0 and 9 
n c5 & c6 must be between a and x
n c7 & c8 must be between 0 and 9 

l The "Time End:" field is entirely optional and you can leave it blank unless you want to save the QSO End Time. Filling in the End Time of a QSO allows the award
processor to identify RagChew QSOs (30 minutes or longer). 

¡ Note: Check the "Time End When Logged, if Blank" to auto-fill the End time when you click the "Log It" button. The logger will insert the current time ONLY
IF it is currently blank. 

l Finally, please notice the "Show Partial Matches" checkbox located directly above the "Previous QSOs with Station" List Box. When selected, the program will search 
the current log for QSOs with the same callsign as the callign is entered character-by-character. 
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Now, with these options in mind, let's look at logging a QSO.

For sprint logging, the program requires you to enter a minimum amount of information before it can be logged. The minimum required fields are:

l Date and Time 
l Frequency OR Band
l Callsign 

Next, enter the callsign of the station being logged and press Tab (or ENTER). If you have checked the "Auto-Fill" checkbox, the program will auto-fill the following fields 
based on the NAQCC membership information for the callsign entered:

l NAQCC Number, if a member
l RST Sent, if set in Program Options 
l RST Rcvd, if set in Program Options 
l City, if available in membership data 
l State, if available in membership data 
l Country, if available in membership data or can be inferred 
l Name, if available in membership data 
l TX Power (your output power), if set in Program Options 

After entering a callsign in the "Call" field, you can either tab out of the field or press the "Check" Pushbutton (Alt-M) to retrieve and auto-fill information retrieved from the
membership list. At this time, any previously logged contacts with this station will be displayed in the list box. QSOs with the same station on the current band will be listed 
in bold font and labeled as "DUPE."

l Note the following actions regarding the Previous QSO's with Station List: 
¡ If the "Show Partial Matches" checkbox is selected, then callsigns that are "LIKE" the callsign entered will be displayed. 
¡ Once a callsign has been finalized, then all previous QSOs with the same Call will be listed but previous QSOs with the Same Call on the Same Band will be 

highlighed with a reddish background. 
¡ You can double click on a specific Previous QSO to open the QSO in the Log Edit Window. 

l You may Double Click on any Previous QSO listed to open the QSO Details in the Edit Window. 

You may also press the "QRZ" Push Button (Alt-Z) to launch a small browser window containing the QRZ.Com webpage information for the callsign entered.

Alternatively, if you hear a NAQCC number but missed the callsign, you can enter the NAQCC number in the "NAQCC" text field and press the "Check" pushbutton (Alt-N).

Note that the State/Country information is actually a best guess based on the information contained in the "SPC" field of the membership data file.

l If the value in the SPC field is one of the standard USPS abbreviations for a US state or US possession, then the SPC value is used as the state and United States is used 
for the country. 

l If the value in the SPC field is one of the standard abbreviations for a Canadian province or territory, then the SPC value is used as the state and Canada is used for the 
country.

Anytime that an Auto-Fill operation would enter data into a field that already is filled, the program will ask you how you want to handle those filled fields. You have three 
options:

l Overwrite All will fill in membership data into all fields. 
l Fill-In Blanks will fill in only fields that currently are blank. 
l Leave As-Is will leave all data fields as they currently are. 

Once all required fields have been entered, the "Log It" button should be enabled. Clicking the "Log It" button will enter the QSO information into the Main Window log list, 
clear all fields (except for Date, Time, Freq, and Band), and place the cursor into the Callsign field.

Note: There are several buttons and text entry fields on the Log Entry window and there are (Alt + Key) shortcut combinations for the following buttons and text entry fields:
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l Alt+C (or Escape) for Clear All 
l Alt+F to enter a Frequency in the QSY Field 
l Alt+M for Check Member Call 
l Alt+N for Check Member Number
l Alt+S for Save Log Entry 
l Alt+Z for QRZ.com Call Lookup 

Next chapter: Sprint Logging

Sprint Logging
The SprintLogger is designed to use the "Tab" key to move from one field to the next. Although you may also use the "Enter" key to move to the next field, be aware that 
once the "Log It" button is enabled, the button becomes the default action for the "Enter" key.

So, for speed logging, one could do the following:

l Enable the Auto Date & Time option
l Enable the Auto Freq & Band option 
l Enable the Auto-Fill log fields option 
l Enable the Auto Log option
l Enter a callsign and click Enter to log with each new QSO.

Next chapter: Submitting to AutoLogger

Submitting Sprint Results to AutoLogger
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After you have completed a NAQCC Monthly Sprint you SHOULD submit your log results to the NAQCC AutoLogger Web page. The AutoLogger expects your submission 
to be in a specifc format and the SprintLogger can generate the report for you.

Two options on the File menu will help you create and submit your results to the AutoLogger.

l "Open AutoLogger Webpage" is provided as a convenience. Clicking the option will launch your default web browser to the NAQCC AutoLogger submission page. 
l "Create AutoLogger Report" is used to generate your sprint results ready for submission.

To generate the AutoLogger report, click the "Create AutoLogger Report" option on the File Menu.

Selecting the "Create AutoLogger Report" option on the File Menu should launch a file creation dialog window similar to this:

By default, the AutoLogger report filename should be the same as the ADIF log file, with "-AutoLogger" appended, but will have a .txt extension replacing the .adi extension.

After the report text file has been created, the text file should open using your default text file editor (normally Notepad) which allows to you select all (Ctrl-A), Copy (Ctrl-C) 
and paste (Ctrl-V) to the AutoLogger Report page.

Next chapter: Tracking Sprint Statistics and SPC Details
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Tracking Sprint Statistics and SPC Details
In most, if not all, NAQCC sprints, the basic sprint score is computed as the number of QSOs times the number of unique SPCs worked - the term SPC refers to State, 
Province, or Country. Each SPC is counted only once for the entire sprint.

As you log QSOs during the sprint, SprintLogger automatically keeps track of the key sprint statistics and displays those values in the lower right corner of its main window.

The total number of QSOs PLUS the number of Member QSOs provides the "QSO Points". That total is then multiplied by the number of unique SPCs logged ("SPC Count") 
to generate a "Raw Score". The Raw Score is then weighted, based on the type of Key used, to generate the final "Sprint Score".

Tracking SPC Multipliers

Some serious sprinters look to increase their sprint scores by accumulating SPC multipliers. Clicking on the underlined "SPC Count" field's label will open a special window
that lists each US state, US possession, Canadian province, and Canadian territory, along with a checkbox indicating worked or not worked. SprintLogger automatically 
checks off the boxes as you collect SPCs. Non-US/Canadian SPCs appear separately as a list at the bottom of the SPC window.

Next section: Timing the Length of a QSO

Timing the Length of a QSO
In some cases it is useful to be able to track the the exact length of a QSO.

At anytime during a QSO, you can click on the underlined "Time:" label in the Log Entry Window to launch a QSO timer. By default, the timer uses the QSO Start Time 
shown in the Log Entry Window as the basis for computing the length of the QSO as compared to the current time.
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The "Stop", "Pause", and "Reset" Push Buttons operate pretty much the same as you would expect on a Stop Watch.

Pressing "Stop" at the time the QSO ends, will freeze the total length of the QSO for you to record in the comments field or elsewhere.

Next section: Editing and Deleting Log Entries

Editing and Deleting Log Entries
After you add an entry to the log, you may find you need to edit or delete the entry. The following subjects provide the details on how to do this:

l Editing a Log Entry
l Deleting a Log Entry

Editing a Log Entry
If you want to edit a single log entry displayed in SprintLogger's main window, you have your choice of three ways to do it:

l Double click on the row containing the log entry; or, 
l Right click on the row and use a pop-up contextual menu; or, 
l Click on a row to highlight it, then click on the "Edit Row(s)" button above the List Box. 

If you want to edit two or more log entries as a batch, you will have to use the "Edit Row(s)" button. The following sections describes the Edit procedure for each method.

Right-Click, Contextual-Menu Method

Right clicking the mouse on a row in the log will cause a context-sensitive, floating menu to appear with three options: "Edit Row", "Delete Row", and "Save Selected As...".

Note: The "Save Selected As..." option is a shortcut to the File->Save Selected As..." function and provides a quick shortcut when you want to save just one QSO entry to a 
log file.
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Selecting "Edit Row" will bring up the Log Edit Window with the selected row's data entered in the text fields.

Virtually all the options available to you when you first make a log entry are available when editing an entry. The primary difference is that you no longer have an option for 
Auto-Date/Time, Auto-Freq/Band, Auto-Fill, or Auto-Log. The Log Edit window also displays and allows editing of two fields that are set in the Program Options window:

l Station Callsign - The Callsign of your station - ADIF Tag: STATION_CALLSIGN 
l Operator Callsign - The callsign of an operator who is NOT the station callsign - usually used for club stations - ADIF Tag: OPERATOR 

You may make any changes you desire, including changing the date, time, frequency, band, call, etc.

Note: The Log Edit process Does Not validate a GridSquare sequence.

You can also check appropriate boxes to indicate whether or not a QSL has been sent and/or received.

When you are finished editing the entry, push the "Save Changes" button to save your changes.

If you find that you don't need to make any changes, just press the "Cancel" button to close the window and cancel any changes made but not saved.

"Edit Row(s)" Button Method

The "Edit Row(s)" button (at the top of the log window) can be used to edit either a single log entry or multiple log entries as a batch. Begin by using mouse clicks to select all 
the rows in the main window's log that you want to edit (use mouse clicks in conjunction with CTRL or SHIFT keys). Then press the "Edit Row(s)" button (at the top of the 
log window).

If you have selected only one record to edit, processing will be identical to the process described for the right-click method described above.

If you have selected two or more rows, you will see a prompt summarizing the first row that you selected and providing you with options to either "Edit," "Skip," or "Quit 
Editing."
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l Select "Edit" to open the log entry in the Log Edit window. 
l Select "Skip" to skip editing the displayed log entry. 

¡ This option provdes a quick way to select multiple records, yet skip a few in the process.
l Select "Quit Editing" to skip the current record and stop the entire process. 

The process described above will repeat for each log entry that you have selected to edit as a batch.

Next Chapter: Deleting a Log Entry

Deleting a Log Entry
If you want to delete a single log entry in the main window's list, you have your choice of two ways to do it:

l Right click on the row and use a pop-up contextual menu; or, 
l Click on the row to highlight it, then press the "Delete Row(s)" button above the log. 

If you want to delete two or more log entries as a batch, you will have to use the "Delete Row(s)" button. The following sections describes the delete procedure for each
method.

Right-Click, Contextual-Menu Method

Right clicking the mouse on a row in the log will cause a context-sensitive, floating menu to appear with three options: "Edit Row", "Delete Row", and "Save Selected As...".

Note: The "Save Selected As..." option is a shortcut to the File->Save Selected As..." function and provides a quick shortcut when you want to save just one QSO entry to a 
log file.

Selecting "Delete Row" from the floating menu will bring up the "Delete Log Entry" dialog box.
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The dialog box lists the date, time, call sign, and frequency of the selected log entry and requires that you confirm your request to delete the entry.

You have two options: "Delete" or "Cancel".

l Click "Delete" to delete the log entry. 
l Click "Cancel" to leave the log entry as is. 

"Delete Row(s)" Button Method

The "Delete Row(s)" button can be used to delete a single log entry or multiple log entries as a batch. Begin by using mouse clicks to select all the rows in the main window's
log list that you want to delete. Then press the "Delete Row(s)" button.

If you have selected only one record for deletion, the processing will be identical to the right-click process described above.

If you have selected two or more rows, you will be provided with a prompt to confirm your request to delete multiple QSO records.

l Select "Yes" confirm your request and delete all of the selected record.
l Select "No" to cancel the request and leave the selected records as is.

Next section: Managing Multiple Radios

Managing Multiple Radios
If you have more than one radio connected to your PC, you may want to have the SprintLogger remember the specific settings for each one.

Setting up a separate configuration for each radio makes it simple and quick to switch between pre-configured radios with the SprintLogger.

There are two basic steps involved in setting up and maintaining multiple radio configurations. The following topics in this section will help you create and maintain those
configurations.

l Adding A New Radio Configuration
l Editing Current Radio Configuration

Adding A New Radio Configuration
To add a new Radio Configuration to the SprintLogger, you must first open the "Radio Setup" window by selecting the "Configure Radio" option from the "Options" Menu in 
the main window.
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If you have a radio currently connected with an open COM port, you must first close the COM port before adding or editing any radio configurations. Close the COM port by 
pressing the "Close Port" button on the Radio Setup window.

The following steps will create a new radio configuration:

l Click the "Config Name" pull-down selector and Select "New Config."

l Set the radio model, COM port, baud rate, parity, stop bits, CI-V port, and flow controls as necessary for the radio you are configuring. 
l Click the "Open Port" button to open the COM port. 
l The SprintLogger will prompt you to provide a unique name for this specific configuration. You may use any name you wish, but each name must be unique -- and 

"New Config" is a reserved name.

l Enter a configuration name and press the "Save Name" button. 

At this point, the port should be open and you should see the Radio Setup window, with the configuration name and configuration parameters you selected. You should test 
the configuration and make sure everything works properly - ensure that you can read and set the radio's VFO.

If you need to make any changes to the setup, just make those changes within the Radio Setup window. The final setup that exists is the one that will be remembered and 
stored for next time.

Next chapter: Editing Current Radio Configurations

Editing Current Radio Configurations
All radio configurations are edited from the "Radio Setup" window. If not already open, open the "Radio Setup" window by selecting the "Configure Radio" option from the 
"Options" menu in main window.
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If you have a radio currently connected with an open COM port, you must first close the COM port before editing any configuration. Close the COM port by pressing the 
"Close Port" button on the "Radio Setup" window.

To open the Radio Configuration Edit window, click on the "Configuration Editor" menu and select "Edit Radio Configurations."

At this point, the "Edit Radio Configurations" window will open. The window will display the configuration name, radio model, and COM port for all radio configurations 
currently set up in the SprintLogger.

All operations from this window are performed on the selected (highlighted) radio configuration item. If a row is not already selected, click on the row that you wish to 
modify.

There are three basic operations you can perform on a Radio Configuration item:

l You can move an item up or down the list; 
l You can rename a configuration. Recall, however, that each configuration name must be unique, and "New Config" is a reserved name;
l You can delete a configuration from the list. 

The steps to complete each of these options is detailed below.

1. To reorder the list, just select the configuration that you want to move and click either the up or the down arrow next to the "Reorder Selected" label.
2. To rename a configuration, just select (highlight) the configuration item and click the "Rename Selected" button.

The "ReName Radio Configuration" window will open with the current configuration name shown in the text field.
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Enter the new name for the configuration and press the "Save Name" button. 
3. To delete a radio configuration from the list, select the item and push the "Delete Selected" button.

A prompt will appear that asks you to confirm the deletion or cancel the request. 

Next section: ADIF Log Files

ADIF Log Files
Even though the program requires that you open an ADIF log file before you starting logging QSOs, the actual QSO information is not stored in the ADIF log file.

The SprintLogger maintains all of your log data in a SQL database on your PC's disk drive in a file named "LogFileDB.rsd." Whenever you save the log data to the ADIF log 
file, the data is copied from the SQL database to the ADIF log file.

Updates to the LogFileDB.rsd database file are made immediately as you enter them and the updates are committed to the database file after each change. Upon a normal 
shutdown of the program, the database contents are written out to the ADIF log file and the database file is deleted.

The following topics in this section will help you understand the relationship between the database file and the ADIF log file.

l Saving Log Data to an ADIF File
l Recovering From an Abnormal Shutdown

Saving Log Data to an ADIF File
Even though all of your log data are stored in an SQL Database file, an ADIF log file is created and written to the log subdirectory within Sprintlogger's main directory.

The log data are saved to the specified ADIF log file at the following times:

l When you select "Save Log Data" or "Save Log Data To..." from the "File" menu. 
l When you open or re-open a log file from the "File" menu. 
l When you select to start a new log file from the "File" menu. 
l When you press the "Save Log" button in either the "Log Entry" or "SprintLogger" windows. 
l When you close the SprintLogger. 

Whenever changes have been made to the log database that have not been saved to the ADIF log file, a "Save Log" button will appear in both the "Log Entry" and 
"SprintLogger" windows.
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Next chapter: Recovering from an Abnormal Shutdown

Recovering From an Abnormal Shutdown
As mentioned previously, the SprintLogger maintains your data in an SQL database on your PC's disk drive.

Updates to the database file are made immediately as you enter them and the updates are committed to the database file after each change. During a normal shutdown of the 
program, the database contents are written out to the ADIF log file and the database file is deleted.

When you first open SprintLogger, the program looks for the log database file in the Logger's home directory. If the database file exists, then the program knows that the 
Logger did not shutdown normally during it's previous run.

When an abnormal shutdown has been detected, you will be presented with a special message at startup telling you that the abnormal shutdown has been detected and giving 
you the option of either recovering the Last Log File or starting the SprintLogger with no log file.

In SOME cases, you will want to recover the Last Log File - A lot depends on what you recall from the last time you shurdown the logger. IF you recall an abnormal 
shutdown due to a program crash, a PC crash, or a power outage, then you will probably want to recover the log data from the database. However, if you suspect that a corrupt 
log file caused the previous abnormal shutdown, then you may want to restart with No Log File. If you choose to start with No Log File, then you can re-open any previous 
log file, or use the "Restore From Backup Log" tool to attempt to recover the log file from the log database.

When you choose to recover the Last Log File, the SprintLogger will create a temporary ADIF Log File from the current log database. You will be provided with an 
informational message regarding the recovered temporary log file.

Although your most recent logging data has been recovered, it is now in a temporary log file whose name is a SprintLogger reserved file name.

You must save Recovered-Log.adi into the SprintLogger's "Logs" subdirectory with an appropriate new file name, using "Save Log As ..." in the main window's "File" menu.

If you continue to use the reserved "Recovered-Log" file, you will receive the following warning every time you open the log.
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Next section: The Tools Menu

The Tools Menu
This section is dedicated to providing insight into some of the Tools and more advanced features of the logger.

The following subjects are included:

l Find - Text Search (Ctrl+F)
l Restoring From a Backup Log
l Resetting Saved Window Positions
l Setting a GMT Correction Factor
l The URL Editor
l Create N#A QSO Log
l Create N#A Summary Report

Find - Text Search (Ctrl+F)
The tool menu item "Find - Text Search" (also activated with Ctrl+F) provides a quick method to search for text within the current log listing.

This option will open the Text Search Window. You enter the text to be searched in the "Search For" text field, select the fields to be searched, and then press either "Find 
Next" or "Find Previous".
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Notes:

l The text search is not case sensitive - "ac2c" will match "AC2C". 
l When the specified text is found, the row containing the text will be highlighted. 
l The column does not have to be displayed for the text to be found. 
l When first activated, the current search row is the top row. 

¡ When searching downward (Find Next), reaching the end of the list will reset the row pointer to the top row.
¡ When searching upward (Find Previous), reaching the top of the list will reset the row pointer to the bottom row. 

l Changing the Search Text will reset the row pointer to the top row. 

Next section: Restoring From a Backup File

Restoring From a Backup Log
The SprintLogger has many features designed to prevent the accidental loss of logbook data. These features include the detection of an abnormal shutdown and the saving of 
all log transactions in an SQL database file on your hard drive.

The SprintLogger provides you with the ability to restore from (or roll back to) a previous version of a log. In order to safely use and get the most benefit from this option, 
please take a few minutes to read and understand just how the logger works and how this capability is provided to you.

As you use the SprintLogger to log your QSOs, the logger keeps track of your actions as follows:

l Every time that you add, edit, or delete a log entry, the change is saved into the log's SQL database file. This database file ("LogFileDB.rsd") resides in the Logger's 
application directory (C:/NAQCC SprintLogger if you followed the installation defaults).

l Additionally, every time you open a new ADIF log file or save changes to the current ADIF file, the program also saves a copy of the log database file.
l Every time the program saves an update to "LogFileDB.rsd," the program automatically saves a copy of the updated file in a special Backup subdirectory (e.g. 

C:\NAQCC SprintLogger\Backups). 
l Each backup file is uniquely named by appending the current Date and Time to the name of the ADIF log file you are currently using. 
l For example, if your current Log file is "AC2C-Sprint-Jan-2013" then a backup file for that log might be named "AC2C-Sprint-Jan-2013 on 2013-01-13 at 12.34.56Z". 
l The program currently keeps up to 50 backup database files in the Backup subdirectory. When a backup file is created, the program checks to see how many backup 

files exist in the directory and starts deleting the oldest files until the total returns to 50.
l Although 50 backup files may seem like a lot, it really does not take long to accumulate 50 backup files. While the primary purpose of this capability is to recover a log 

in the event of a catastrophic event or operator error, this option may also be used to roll back your log to a previous state. 

Now, with all the above in mind, let's see how to restore your log from a backup database file.

Note: You should save any current changes to your current log file before continuing.

Select the "Recover From Backup" option from the Tools menu on Logger's main window.
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Selecting the "Recover From Backup" option will result in a "File Open" dialog window that will display the current contents of the Backup subdirectory.

Use whatever standard sort/view options you want to look through the various backup files. If you are looking for a specific name, then you may want to sort by filename. 
However, if you are looking for a specific time, then you may want to sort on creation date.

Once you have found the backup file you want to use, select the file and click the "Open" button to load the data in the backup file or click "Cancel" to cancel the restore
process.

When you select to restore from a backup, the program uses the data in the backup file to create a temporary log file with a special name of "Recovered-Log" and saves the 
log file in the application's main directory (e.g. C:\NAQCC SprintLogger). You will see the following warning displayed:

Press "OK" to continue. You can now review the contents of the recovered log and make sure it is the one you want. If not, just start over and open a different backup file.

Once you have recovered the file that you wanted, you MUST save the log file in your Logs subirectory with an appropriate file name.

If you continue to use the reserved "Recovered-Log" file, you will receive the warning every time you open the log.

Next section: Resetting Window Positions

Resetting Saved Window Positions
The SprintLogger provides a user-selectable option to save and recall the position and size of the various windows the program uses. For the most part, those options provide 
adequate day-to-day control of where on your screen the various windows appear.

There are, however, at least two situations where the basic logic of the processing might fall apart:

l A user may have two or more monitors and has windows displayed on a monitor other the main monitor. If that user removes or reconfigures the additional monitors, 
then a window may try to restore itself to a screen position that no longer exists. 

l A user may adjust the screen resolution of a monitor at any time. If the new resolution setting has fewer pixels that the last setting, a window may try to restore itself to 
a screen position that no longer exists. 

If you ever get into a situation where you are trying to open a window and the window just will not display, then you may reset the position of all program windows through 
the Tools Menu.

Note: Only positions of fully closed (not minimized) windows can be reset. You may not see a window, but it may still appear on the Windows
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desktop's task bar. You can close applications from the task bar.

Selecting "Reset Window Positions" will result in a dialog window asking you to confirm your request.

Press either "OK" to complete the action or "Cancel" to close the window and do nothing.

Next chapter: Setting a GMT Correction Factor

Setting a GMT Correction Factor
On most Windows PCs, the user sets the local time and also tells the Windows Operating System (OS) the local time zone. Those two items together allow the PC to know the 
time difference between the Local time and GMT. The SprintLogger program relies on the time difference information provided by the Windows OS to convert local time to 
GMT for logging purposes.

If, for whatever reason, you are unable to get the SprintLogger to log correct GMT dates and times, you can specify a special offset value to be used in computing GMT from 
your PC time setting.

Select "Set GMT Correction Factor" from the Tools Menu.

Page 28 of 34NAQCC SprintLogger User Guide

8/24/2019file:///C:/Users/Ron/AppData/Local/Temp/~hh9AB6.htm



This option will open the Set GMT Correction Factor Window. The window displays the current correction factor along with the current local PC Time and the current GMT 
Time computed using the correction factor.

The window shown indicates an offset of 0.0 that results in GMT being five hours ahead of local time - My PC is in the USA Eastern Time Zone.

To change the correction factor and test the GMT time resulting from the new correction factor, enter a number in the "Correction" field and press the "Test It" button to see 
the GMT time resulting from your correction factor.

When you find a correction factor that gives you the correct GMT time, press the "Save" button to set and remember the correction factor you have specified.

Next section: The URL Editor

Using the URL Editor
The tool menu item "URL Editor" provides a method for the user to Edit the web URLs used by the logger.

Selecting this option will open the URL Editor Window. The window will open displaying the URLs currently used by the logger.
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You can enter new URLs and test the links using the "Open URL" buttons. Once you are satisfied with any changes you make, you can press "Save and Close". All changes 
made will stay in effect UNTIL you edit them again.
Note: The default URLs MAY also be changed in a future upgrade of the logger.

You can restore the defaults to those provided with the original logger download using the "Restore Default" buttons and can discard any changes made by clicking on 
"Cancel and Close".

Next section: Create N#A QSO Log

Creating a Anniversary (N#A) Event Log File
The tools menu item "Create N#A QSO Log" provides a method for the operator to create a text log file for submission.

Selecting this option will open the NAQCC Anniversary QSO Log Generator.
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The FIRST time the window is opened, the text fields will be blank but will be remembered and will auto-fill after the appropriate information has been entered and a log 
report generated. Make sure to fill in every text field.

Note: Since you may need to submit a log prior to the final log, you MUST select/highlight the QSOs in the Main Log List Box that you want included in the log report. After 
you have selected the log entries to be included, press the "Create Log" button. If all goes as expected, the log report should be generated and the text file will be opened for 
your review.

Assuming the text file meets your approval, make a note of the name and folder (same as the log file) for attaching to an email.

Next section: Create N#A Summary Report

Creating a Anniversary (N#A) Event Summary Report File
The tools menu item "Create N#A Summary Report" provides a method for the operator to create a summary report text file for submission.

Selecting this option will open the NAQCC Anniversary Summary Report Generator.
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By the time you use this generator you should have already generated a QSO Log submission so the text fields should auto-populate.

Note: Since the summary reports is for the entire event, the report will include every QSO in the log file and there is no need to select any QSOs in the Main Log List Box. 
After you have validated the Text Field entries, press the "Create Report" button. If all goes as expected, the summary report should be generated and the text file will be 
opened for your review.

Assuming the text file meets your approval, make a note of the name and folder (same as the log file) for attaching to an email.

Next section: Appendices

Appendices
The following Appendices provide specialized information of interest to some users.

l Running Multiple Copies Simultaneously
l Revision History

Running Multiple Copies Simultaneously
Some users have requested the ability to run two or more copies of the SprintLogger simultaneously.

Running multiple copies of the program allows for some advantages, but also has some risks.

Advantages:
¡ Ability to have two or more log files open simultaneously; 
¡ Ability to control two or more radios simultaneously; 
¡ Ability to check for QSOs in one log while logging into another log. 

Risks:
¡ You might inadvertently be making changes to the same log file. In this case, each copy of the program is keeping it's own database file and the last program to 

save it's copy of the log. will replace the copy saved by the other copies. 
¡ With multiple versions running simultaneously, there is a risk that you might lose track of which log you are modifying at any one time. 

With these advantages and risks in mind, the SprintLogger program has been developed to allow the simultaneous operation of multiple copies of the program. However,
there are some restrictions.
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Run multiple copies of the SprintLogger with extreme caution and at your own risk.

If you have installed a single copy of the Logger into a single folder/directory on your PC, an attempt to launch the program while a current copy is running will result in the 
following warning window.

As soon as you click the "OK" button, the newly launched program will immediately shutdown.

As described in the warning, IF you want to operate multiple copies of the program, then you must install multiple copies of the program into separate folders. Additionally, 
each separate folder MUST be uniquely named.

You can create multiple installation copies of the SprintLogger in one of two ways - pick whichever you feel most comfortable with:

l Run the Logger Setup program and override the defaults to specify your own directory/folder; or, 
l Copy the contents of your current Logger directory/folder to a new folder that you have created and renamed.

As long as you keep your folders and log files separate theye should be no issues or problems with running multiple copies of the SprintLogger. If you venture into having the 
same log file from the same folder/directory open in two or more instances of the logger, be extremely careful about making changes to te log file. As stated above, if two or 
more programs have the same log file in the same folder/directory open and make changes, then the last program to save the log will replace the log saved by other programs.

Run multiple copies of the SprintLogger with extreme caution and at your own risk.

Next section: Revision History

Revision History
v01.00.05: 24-Aug-2019:

¡ Bug Fixes: 
n Fixed AutoLogger Report generator to correctly handle DX stations. 

¡ Changes to previous processing methods: 
n None. 

¡ New Capabilities & Features: 
n Modified Anniversary report processing to use N3A/# callsign in place of N#A callsigns. 

¡ Changes to how the program works - not "seen" or necessarily noticed by the user:
n Memebrship Download URL is no longer hard coded.

v01.00.04: 16-Feb-2019:

¡ Bug Fixes: 
n Handled UnsupportedFormatException when re-opening a log file saved with a relative path. 
n Fixed a bug that appeared to add QSL S/R info from a previously edited record. 

¡ Changes to previous processing methods: 
n None. 

¡ New Capabilities & Features:
n Added report generation processing for Anniversary (N#A) operators. 
n Added ability to edit Contest ID in Program Options.

¡ Changes to how the program works - not "seen" or necessarily noticed by the user: 
n Contest ID "NAQCC Sprint" is added to ADIF log file for all new log entries. 
n Checked for 2-character string when matching State or Province Postal Codes. 
n Modified processing to retrieve Member information to use Member Callsign instead of NAQCC Number. 
n Added code to handle multiple callsigns for one NAQCC Number.

v01.00.03: 28-Apr-2018:

¡ Bug Fixes: 
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n None.
¡ Changes to previous processing methods: 

n The "Create AutoLogger Report" processing will no longer create a report file UNLESS a callsign has been entered into the Program options Callsign field.
¡ New Capabilities & Features: 

n Added File Menu option to launch your web browser to the AutoLogger submission page.
n Added support for the Icom IC-7610. 

¡ Changes to how the program works - not "seen" or necessarily noticed by the user:
n Added AutoLogger suibmission page to the URL Editor.

v01.00.02: 23-Feb-2018:

¡ Bug Fixes: 
n None.

¡ Changes to previous processing methods: 
n None.

¡ New Capabilities & Features: 
n None.

¡ Changes to how the program works - not "seen" or necessarily noticed by the user: 
n Changed Defaults URLs to begin with "http://". 
n Minor change to tags in INI file for URLs used.

v01.00.01: 6-Jan-2018:

¡ Bug Fixes: 
n None.

¡ Changes to previous processing methods: 
n Added code to display PDF Version of User Guide if the HTML Version was not available. 
n Changed named of exported Text, CSV, and AutoLogger files.

¡ New Capabilities & Features: 
n Added URL Editor Window with NAQCC Zip File Download and QRZ Lookup URLs. 
n >Modified COM Port Opening processing for MacOS compatibility. 

¡ Changes to how the program works - not "seen" or necessarily noticed by the user:
n Several minor tweaks made to make logger compatible with MacOS Systems. 
n Added new FileType "ADIFExport" for MacOS compatibility.

v01.00.00: 24-Nov-2017:

l Initial, non-Beta, release.
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